re:Members AMS Platform Alert Notification: Data Share

Incident Report for reMembers AMS

Resolved

Service Alert Update: Snowflake Access Disruption
Status: Resolved
Posted: Jun 16, 2026 - 04:00 UTC

Snowflake's third-party cloud provider has confirmed the underlying infrastructure issue was resolved as of 21:45 UTC on June 15th. Systems are stable and we are closing out this incident on our side. We will post a new alert if any further impact is identified.

For additional details, visit: status.snowflake.com
Posted Jun 16, 2026 - 12:15 EDT

Update

Service Alert Update: Snowflake Access Disruption
Status: Monitoring

Latest post: Jun 15, 2026 - 19:22 UTC

Post summary: Services are currently stable. Snowflake is continuing to monitor.

For additional details and real-time updates, go to: status.snowflake.com
Posted Jun 15, 2026 - 17:35 EDT

Monitoring

Service Alert Update: Snowflake Access Disruption

Snowflake has implemented recovery actions and reports that service health has returned to normal; however, intermittent performance impacts may continue while the underlying infrastructure issue is being addressed.

Snowflake is actively monitoring. We will share updates as they become available.
Monitor Snowflake's status page for real-time updates: status.snowflake.com
Posted Jun 15, 2026 - 14:30 EDT

Investigating

Service Alert: Snowflake Access Disruption

We are aware of an active Snowflake incident that may impact Data Share clients. Affected regions have not yet been identified. Customers may be unable to access Snowflake services and features.

This is a Snowflake platform issue; you can monitor their status page for real-time updates: status.snowflake.com

We will provide updates as more information becomes available.
Posted Jun 15, 2026 - 11:19 EDT
This incident affected: API, Cloud 1, Cloud 2, Cloud 3, Cloud 4, and Cloud 5.